Sunday, June 03, 2007

Technical Update

New Browser Support
When I set out to do this blog I decided to stick few gadgets on it to liven it up a little bit, like the Microblog, Twatometer, Dictionary and the new Campaign slide show. I really only know the insides of Internet Explorer well enough to write the code so that's all that was supported. Someone kindly let me know that the some of the stuff actually crashed Firefox, so I apologise to anyone who has run into this.

I've finally bitten the bullet and downloaded the latest versions of Firefox and Opera and managed to make everything safe, and almost everything work with these browsers. I don't have access to a Mac so I can't guarantee anything on this platform, or on Safari for example, but once adapted for Firefox there was very little needed to make it work in Opera so hopefully the blog is close enough to standards that it should work OK.

Am I a convert? Not really. Both Opera and Firefox seem perfectly good browsers, but I'm happy enough with IE. Does it seem that these browsers stick closer to standards? Yes. Is the new standards compliant code much uglier than the old elegant IE only version? Yes to that too I'm afraid.

No comments: